ih8sn0w discovers an APTicket loophole which allows downgrading iPad2 and iPhone4S from 5.1 to 5.0.1

Just a few minutes ago, @ih8sn0w the creator of Sn0wbreeze announced on Twitter that he has found a loophole in 's APTicket system which allowed him to his from 5.1 to . He went on to say that the loophole not only works on the iPad2, but also the iPhone4S. Also, he has stated that once a new firmware is released for the iPad3, the loophole will also work to that device.

At this point, we don't have much information about this loophole or how/when it will be implemented into the the jailbreak tools, but there appears to be hope for those with A5 devices who either intentionally or "accidentally" updated their devices to 5.1 and are no longer able to jailbreak.

Stay tuned as we find out more!