Ultrasn0w 1.2.5 adding 5.0.1 unlock support to be released later today

Just a bit ago, @MuscleNerd announced the released of Redsn0w 0.9.9b9 which adds native compatibility as well as a bunch of new features. One footnote you may have missed is that later today(Monday) Ultrasn0w 1.2.5 will be released to add support for iOS 5.0.1. Until now you have had to use the 5.0.1 fix in order to unlock on that , with this update of you will no longer need to do that.

To be clear, this does NOT add support for any new basebands, only compatibility with the 5.0.1 firmware for basebands which have already been deemed unlockable.

  • bloodseeker

    First off all, thx for the fix !

    Hint: For all 3GS Users with IPad Baseband 06.15.00 , if you restore over Itunes, install the IPad baseband over Redsn0w again, U-sn0w it and the SIM works fine.

    Regards

    • Carlo

      Hello I jailbroke and changed my baseband to 06.15.00 on my 3gs and had to restore but didn’t restore the baseband over Redsn0w and now the phone will not read my sim. Any way I can still fix this? The phone is stuck in the activation process and will not even load the spring board because it says it does not detect a valid sim. I appreciate your help in advance.

      • http://iphoneblogr.com JaeM1llz

        Reinstall the iPad baseband.

  • Fromagi

    thanks from here too! I just have a question:
    Is the new jailbreak software published today (dece 19th 2011) by ultrasnow allowing unlock of baseband (modem firmware) 04.11.08 on ios 5.0.1? I understand this will be a tethered jailbreak but that doesn’t matter, what matters to me is the possibility to unlock after the jailbreak…

    • http://iphoneblogr.com JaeM1llz

      There is no way to unlock the 04.11.08 baseband, like it says in the post this does not add compatibility with any new basebands, just adds support for the already unlockable basebands on firmware 5.0.1.

  • http://itsmyphone.co Aegides

    nice, any idea on the 4.11.08 unlock?

  • Cicero

    Will it ever be possible to unlock baseband 04.11.08 or at least be able to downgrade for a possible unlock??

    • http://iphoneblogr.com JaeM1llz

      There is no way to downgrade baseband. There will probably never be a software unlock for 04.11.08, but supposedly a new SIM interposer hack is going to be released within the next month for $100 USD.

  • Jakob

    Or did they mean next Monday, like some other sites suggests?

  • Pingback: iPhone-Dev Team website and repo down for infrastructure update | iPhoneBlogr.com

  • Pingback: Ultrasn0w 1.2.5 for iOS 5.0.1 compatibility available now | iPhoneBlogr.com