Sherif_hashim Confirms Ultrasn0w Will Unlock Both iOS 4.1 AND iOS 4.2.1 (Baseband’s 05.14.02 AND 05.15.04)

Yesterday I posted that MuscleNerd has confirmed the new Ultrasn0w will be available by the end of the week! What was unclear at the time was which it would unlock.

Yesterday I asked both MuscleNerd and Serif_hashim directly via twitter, as seen below:

This is huge news! For all those who have updated to , you ARE in luck! As of Sunday, you will have an unlock again!

To clarify, the new Ultrasn0w unlock, confirmed to be here by Sunday at latest will unlock both () and iOS 4.2.1 (iOS ).

  • Corey

    Finally! Thanks dude for the info!

  • Ab

    Do I need to be jailbroken with anything in particular, or is orig jailbreakme.com on 4.0 ok? I have baseband 05.14.02, on a jailbroken 3GS running 4.0.1. Will I need to do anything as a pre req? Or just wait till it comes out and add it in Cydia?

    • http://iphoneblogr.com JaeM1llz

      It doesn’t matter which jailbreak you use, as long as you have access to Cydia so you can download and install the ultrasn0w package, you can use it. Thanks!

      • Ab

        Thank you!

  • Kai

    I have already jailbroken 4.1 and have been waiting for the unlock on my 3G. Is it now safe to upgrade to 4.2.1 (and iTunes 10.1) and just re-jailbreak using RedSn0w? Then when Ultrasn0w drops, use that to unlock my phone?

    Thanks for the advice and HUGE thanks to the Dev Team for their tireless work.

  • Nick

    Amazing news! I just updated to ios 4.2.1 on my 3Gs and jailbroke it with redsn0w, all I need is that unlock now :D

    Thanks for the info, this was the only spot I was able to find solid evidence of an unlock for 5.15.04

  • macrules

    so strictly not an unlock, but a workaround by upgrading the baseband, which at the moment seems to have some gps trouble.
    Just read the dev-team site and see.

    I am still eagerly waiting for the 02.10.04 unlock, like a big part of the iPhone 4 owners :).

  • shashank

    I have iPhone 3G, Version 4.2.1 (8C148)
    Modem Firmware (BaseBand) 05.15.04
    I used Ultrasn0w through Cydia on my iPhone but still I am getting Error “Unable to load network list” while trying to choose Carriers.
    Please Help

    • JaeM1llz

      You must update your baseband to 06.15.00 before the unlock will work. Please refer to the 06.15.00 tutorial