Errors Occurring When Installing Plex On Apple TV 2G [solved]

We have had reports from viewers that they have recently had problems when attempting to install Plex on the Apple TV. The installation was working for some time and any viewers have shared their on the easy installation process due to our video tutorial released here earlier.

We have had reports that there have been errors when trying to complete the last steps of the installation process.

1

Viewers are receiving this error:

, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or is only available from another source

However the following packages replace it:

E: Package plex-client-plugin has no installation candidate

To fix this error please do the following:

1. Remove the older version
apt-get remove plex-client-plugin

2. Update again the packages information
apt-get update

3. Install the new version (the name of the package has changed)
apt-get install com.plex.client-plugin

4. Restart the GUI
killall Lowtide

Error 2

Also, we have had reports of this error:

W: GPG error: http://apt.awkwardtv.org ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 89711CE585F73AB5

To fix this error, enter the following into Terminal:

apt-get install wget
wget -O- http://awkwardtv.dyndns.tv/awkwardtv.pub | apt-key add -

Error 3

Also, we have had reports of this error:

The following packages have unmet dependencies:
libxml2-lib: Depends: firmware (>= 3.0) but it is not installable or
libxml2-dylib but it is not installed
sqlite3-lib: Depends: firmware (>= 3.0) but it is not installable or
sqlite3-dylib but it is not installed

To fix this error, enter the following into Terminal:

apt-get -f install

Error 4

People are receiving this error when ssh'ing into their device:

@@@@@@@@@@@@@@@@@@@@@@@@@@
@ REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
----------------------------------------------------

To fix this error, click here for a quick tutorial on how to change your Known_hosts file.

Error 5

The ’ could not be restored. This device isn’t eligible for the requested build.

Apple TV error

Click here for an explanation of what this error means and how to solve it.

Please let us know your feedback, has this solution worked for you? Leave a comment below or send us an email using the form located along the menu above or by clicking here.

  • Pingback: How To Install Plex Onto Apple TV 2G – Play Almost Any Video File Type – Video Tutorial | iPhone Blogr

  • Sunashton

    To solve the problem, just do as the error indicates:

    1. Remove the older version
    $ apt-get remove plex-client-plugin

    2. Update again the packages information
    $ apt-get update

    3. Install the new version (the name of the package has changed)
    $ apt-get install com.plex.client-plugin

    4. Restart the GUI
    $ killall Lowtide

    Done.

    • http://iphoneblogr.com JaeM1llz

      Thanks for this solution!

  • http://mychal.net Mychal

    Change Command 5 to:

    apt-get install com.plex.client-plugin

    Works fine, just installed it yesterday.

  • o

    cheers that worked

  • madhesh

    well it worked. working fine.

    Few issues.
    Video plays for an Hour and gets to the home screen .
    Why forward and rewind option not available.Again play the movie from the first.
    I know it is early stages ,if there is any solution update us.

    • http://iphoneblogr.com thescragster

      Hi Madhesh,

      Thanks for your comment. You’re right, this is still in it’s very early stages of development. There are still issues.

      For example, the fast forward/rewind option is not there/not working.. We will update you as soon as we hear of any changes/updates.

      Thanks

  • GeorgeV

    You might want to run `apt-get -f install’ to correct these.
    The following packages have unmet dependencies:
    libxml2-lib: Depends: firmware (>= 3.0) but it is not installable or
    libxml2-dylib but it is not installed
    sqlite3-lib: Depends: firmware (>= 3.0) but it is not installable or
    sqlite3-dylib but it is not installed
    E: Unmet dependencies. Try using -f.

    • http://iphoneblogr.com thescragster

      Thanks, I have added this to the tutorial :)

  • x74353

    I’ve tried this over and over and the plex plugin for apple tv 2g is working and all, but I can’t get any of the video plugins to show up (except vimeo). hulu, NBC, etc. just don’t show up at all. these plugins work just fine on the desktop version of plex. anyone know why these plugins don’t show up at all in the apple tv? btw, vimeo plays video just fine. my mac more than meets any minimum system requirements, and I do not have flash 10.1 installed. I’ve set the preferences for plex to show beta updates, and then tried running “update” from the plex online menu option, but no updates are available…

    • http://iphoneblogr.com thescragster

      At the moment, this is stil a very experimental plugin.

      Functionality is still very limited, I do not think video plugins are available for Plex Apple TV client yet. Hopefully this will be added in an update sometime soon.

      Thanks

  • Carlos Echevarria

    I’m trying to enable the higher quality settings.
    However I get error all of time. Can some please advised how they got this done.
    Thanks.

    curl http://ambertation.de/downloads/PLEX/ffmpeg > ~/Downloads/ffmpeg
    cp ~/Downloads/ffmpeg ~/Library/Application\ Support/Plex/Plex\ Media\ Server.app/Contents/Resources/

    • http://iphoneblogr.com thescragster

      Hi,

      Are you trying to play 720p or 1080 files? Plex only supports 720p files at the moment.

      Thanks

  • brian

    I got “Error 2″ for the apt.awkwardtv.org key and loaded it easily thanks to your info :)

    However, I’m getting the same error for the saurik.com key…

    W: GPG error: http://apt.saurik.com tangelo-3.7 Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 6D36863DAA31C175

    I don’t see a public key file on that site, any ideas how to get that one?

    • http://iphoneblogr.com thescragster

      Hi Brian!

      Great to heard things went well.

      No unfortunately I don’t know where this key would be. Which package are you wanting to install?

  • Philippe

    I’m getting this error after I enter line 5:

    /usr/bin/apt-key: line 161: run-parts: command not found
    –2010-11-23 11:52:37– http://apt.awkwardtv.org/awkwardtv.pub
    gpg: Invalid option “-apt-get”
    Resolving apt.awkwardtv.org… 67.23.32.211
    Connecting to apt.awkwardtv.org|67.23.32.211|:80… connected.
    HTTP request sent, awaiting response… 200 OK
    Length: 1698 (1.7K) [text/plain]
    Saving to: `STDOUT’

    0% [ ] 0 –.-K/s in 0s

    Cannot write to `-‘ (Broken pipe).

    Any idea? Thanks

    • http://iphoneblogr.com thescragster

      Hi Philippe,

      I have not seen the error before, try starting from the start of the tutorial again and see if you get it a second time.

      Let us know if it solves the problem :)

  • Pingback: Run Plex on AppleTV 2G | LinOSX TechnoMash

  • alp

    I installed plex 2 times. every time from the beginning but each time I have the same problem. I want to play a movie but there an error message “An error occured loading this content. try again later”

    what am i suppose to do please help me

    • Avril

      Did you get a fix for this?!

  • Neil

    I am getting this error when I try to update or install plex

    Reading package lists… Error!
    E: Problem parsing dependency Depends
    E: Error occurred while processing org.tomcool.screencapture (NewVersion1)
    E: Problem with MergeList /var/lib/apt/lists/apt.awkwardtv.org_._Packages
    E: The package lists or status file could not be parsed or opened.

    • Dan

      I’m having the same issue… It’s driving me crazy

    • Apple2

      I have the same problem, I have rejailbroken it twice to no avail. any help would be great :)

      • http://iphoneblogr.com thescragster

        Hi guys!

        I posted last night about this error. Click here to read about it.

        I contacted NitoTV directly about this problem and he was able to sort it out for us.

        If you re-follow the tutorial it will now work!

        Let me know how you get on :)

        • Neil

          So I tried it and got past the first error but now I am having the following problem.

          Apple-TV:~ root# apt-get install com.plex.client-plugin
          Reading package lists… Done
          Building dependency tree… Done
          The following extra packages will be installed:
          beigelist mobilesubstrate
          The following NEW packages will be installed:
          beigelist com.plex.client-plugin mobilesubstrate
          0 upgraded, 3 newly installed, 0 to remove and 6 not upgraded.
          Need to get 69.6kB/1027kB of archives.
          After this operation, 1892kB of additional disk space will be used.
          Do you want to continue [Y/n]? Y
          Get:1 http://apt.saurik.com tangelo-3.7/main mobilesubstrate 0.9.3367-1 [69.6kB]
          Fetched 1B in 0s (2B/s)
          Failed to fetch http://apt.saurik.com/debs/mobilesubstrate_0.9.3367-1_iphoneos-arm.deb Size mismatch
          E: Unable to fetch some archives, maybe run apt-get update or try with –fix-missing?

          What can I do to fix this?

          • http://iphoneblogr.com thescragster

            Try doing the following command again:

            apt-get update

            Then apt-get install com.plex.client-plugin

            See if that sorts it – let me know how you get on

  • Neil

    I was able to get it….I found out the ISP I was on had a block on that site so I found another ISP and was able to get Plex. Works well! Thanks for all the help.

    • aos2

      Hi
      I dont know if this is a Plex problem or a server problem. I get the Plex app in my menu, but i just get up my servers name, but no response what so ever trying to get to the server. I had it working, but after a new installation it will not work for me. I did try too install it over again but it wont work for me.

  • Pingback: How To Install Plex Onto Apple TV 2G – Play Almost Any Video File Type – Video Tutorial | AppleTVBlogr.com | Apple TV Jailbreaking and Modding

  • Pingback: How To Install Plex On Your New Apple TV | Lifehacker Australia

  • Pingback: Jamie Angel » Blog Archive » How to Install Plex on Your New Apple TV [Video]

  • copix

    The following packages have unmet dependencies:
    com.plex.client-plugin: Depends: org.awkwardtv.whitelist but it is not installable
    E: Broken packages

    • http://iphoneblogr.com thescragster

      There seems to be a problem with the awkwardtv server at the moment. We will post an update when things are sorted out

    • JaeM1llz

      Add this temporary repo http://awkwardtv.dyndns.tv/

  • copix

    W: Failed to fetch http://apt.awkwardtv.org/./Packages.gz HTTP/1.1 404 Not Found

    E: Some index files failed to download, they have been ignored, or old ones used instead.

  • sky1ne

    Please update your commands.txt:

    Command 2.
    echo “deb http://awkwardtv.dyndns.tv ./” > /etc/apt/sources.list.d/awkwardtv.list

    Your Error list above – Error 2 must now be:

    apt-get install wget
    wget -O- http://awkwardtv.dyndns.tv/awkwardtv.pub | apt-key add -

    • JaeM1llz

      Fixed, thank you!

  • neo2ryu

    i’m having problem with the last command “killall lowtide”it is givin me “No matching processes were found”.
    so please help

    • http://iphoneblogr.com thescragster

      Hi Neo2ryu,

      The app lowtide has been changed in the latest firmware upgrade. Try using “killall appletv.app”.

      Alternatively, just unplug the AppleTV from the wall and plug it back in. Let me know if that solves it.

      Thanks

      • neo2ryu

        thank a lot thescragster it worked just fine thanks.

  • http://iphoneblogr.com thescragster

    Hi Casper,

    The app lowtide has been changed in the latest firmware upgrade. Try using “killall appletv.app”.

    Alternatively, just unplug the AppleTV from the wall and plug it back in. Let me know if that solves it.

    Thanks

    • noname

      the “killall appletv.app” and “killall lowtide” didn’t work. What to do`

      • http://iphoneblogr.com JaeM1llz

        One of those two commands will work depending which firmware you are on.

  • neo2ryu

    another problem!!!
    when i want to stream any video on plex from my library or the server it just gives me a black page and nothing plays???

    is it plex error or there is something i have to do.

    Please help

    • chris

      Same here….everything had been working great than I did an update all in nitotv and after that Plex wouldn’t stream any video I’ve installed and uninstalled and even a hard reset of the apple tv no go

  • Bennsen

    I think the plex repo is down!!

    an here is the plex update….

    but i use the new repo to install the update :( please help to find a new plex intall introduction

    here is the pley update: http://forums.plexapp.com/index.php/topic/20051-plex-client-for-apple-tv-2g/page__view__findpost__p__136459

  • Bennsen

    Has some one a new istall insturction?

    • JaeM1llz
    • Eric Jarvies

      Below is what it took to successfully install PLEX on my ATV2 with Firmware 4.2.1:

      -ssh root@atv2.ip.address

      -cd /private/var/root/

      -wget http://dl.dropbox.com/u/16129573/com.nito.deb

      -echo “deb http://apt.awkwardtv.org ./” > /etc/apt/sources.list.d/awkwardtv.list


      -echo “deb http://www.ambertation.de ./downloads/PLEX/” > /etc/apt/sources.list.d/plex.list

      -wget -O- http://apt.awkwardtv.org/awkwardtv.pub | apt-key add –

      -dpkg -i com.nito.deb

      -apt-get update

      -apt-get install com.plex.client-plugin

      -rm /var/lib/dpkg/info/com.plex.client-plugin.postinst

      -apt-get install com.plex.client-plugin

      -ln -s /Applications/Lowtide.app/Appliances/PLEX.frappliance/ /Applications/AppleTV.app/Appliances/PLEX.frappliance

      -apt-get install beigelist

      -killall AppleTV

      -apt-get update

      -apt-get upgrade

      I strongly suggest you do NOT run ‘apt-get install com.nito.nitotv’ as that seems to cause a lot of problems, resulting in having to start over from scratch(iTunes, jailbreak & PLEX installs).

      Good Luck!

      Eric Jarvies

  • apityesz

    where is the solution for Error 4??

    • JaeM1llz

      Error -4 seems to be a Mac only issue, try this: Go to system preference -> network and then at the top you will see location. Click edit and just make a new one. Then try again.

  • Ericker

    If you have this error

    Apple-TV:~ root# killall Lowtide
    No matching processes were found

    Try

    killall AppleTV

    and will work, Apple tv 2gen

  • fryphone

    I jail broke my appleTV with Greenpois0n. NitoTV is installed and I am trying to install PLEX. It allows me to get to the end apt-get install com.plex.client-plugin and it gives me this error.

    Get:1 http://www.ambertation.de ./downloads/PLEX/ com.plex.client-plugin 0.7.0 [787kB]
    Fetched 1B in 0s (2B/s)
    Failed to fetch http://www.ambertation.de//downloads/PLEX/.//PLEX.frapplication_0.7.0.deb Size mismatch
    E: Unable to fetch some archives, maybe run apt-get update or try with –fix-missing?

    Please Help! Thanks!

  • Ibraham

    Hey, when i type my apple TV IP address in “terminal” it asks me to type the password and when i try to write something, it wouldn’t let me type any letter as if the whole keyboard ain’t working but the “Enter” button, and when i click “Enter” it says “Permission denied, please try again.”
    Please let me know what should i do?

    • http://iphoneblogr.com thescragster

      Hi there,

      When you are typing your password, Terminal hides the characters that you are typing (for security reasons). Just type your password (default is alpine) and hit enter. Do not worry that it is not being displayed :)

      Thanks

  • Brian Nelson

    Hi I was just curious if all of the options from plex are available to use when jailbroken over apple tv, i.e (video plug-ins, and audio plug-ins like pandora or being able to watch tv episodes online)?

  • Nick

    is anyone having frameskipping issues with netflix since they installed plex on aptv2. I had this before so I started from scratch, tested netflix prejailbroken, then jailbroken and no issues, but after the plex install i get a skip in netflix vieo every 30 secs or so. Any thoughts?

  • Apires2

    Hi,
    Does anyone has this message when enter in the host 10.0.1.20 , I have the error operation timed out port 22.
    I am trying to get Plex on my Apple tv and keep failing miserable!

  • Apires2

    Hi, after much trying I have now the following error; 
    Could not resolve hostname root () : nodename nor servname provided, or not knownAlessandras-MacBook-Pro:~ apires2$ Do you know what I need to do to  fix this?
    Many Thanks